Library Proxy Service Error
Modified on: Wed, 11 Jun 2025 10:10 AMIntroduction
This article describes an error message in which a CCID is flagged as expired by the Libraries' Proxy Service. In addition to describing the symptoms and cause of the issue, a resolution is provided.
Applicability
This article is for use by all users with a valid CCID attempting to access Library resources.
Symptoms
- You experience multiple failed attempts to log in to any CCID protected service.
- You experience the following error message when attempting to access the Libraries' Proxy Service:
- "The Libraries' Proxy Service, which is used to access licensed resources from off-campus, shows that your CCID was used simultaneously or within a short time frame from multiple geographic locations. Your CCID Username and Password were logged into the Proxy Service from multiple locations as follows:"
Cause
- You may receive this error if your CCID password requires a reset.
- This issue is generally created when you attempt to access the Libraries' Online Resources from multiple geographic locations within a restricted time frame.
- It can be falsely triggered if you attempt to log-in while using a VPN service and then a local address OR if you attempt to log in from a location where access is restricted due to high levels of risk.
- The CCID password is expired by the system which forces you to change your password in order to log in again.
Resolution
Follow the Reset a CCID Password article for guidance on resetting your password.
Alternately, you may contact the Shared Services Staff Service Center to request assistance with resetting your password.